« openssl 0.9.8 + apache2 | トップページ | アクセプト »

2005.07.11

mod_ssl 2.8.23 がリリースされました


apache1.3.33 用の mod_ssl で 2.8.23 がリリースされました。

トップ画面で
===
06-Jul-2005: Released 2.8.23-1.3.33: For OpenSSL 0.9.8!
===
とありました。

んで、PEM_F_DEF_CALLBACK の部分を見てみると、ありました、ありました。
./pkg.sslmod/ssl_engine_pphrase.c の 496行目
===
#if SSL_LIBRARY_VERSION >= 0x00908000
PEMerr(PEM_F_PEM_DEF_CALLBACK, PEM_R_PROBLEMS_GETTING_PASSWORD);
#else
PEMerr(PEM_F_DEF_CALLBACK, PEM_R_PROBLEMS_GETTING_PASSWORD);
#endif

===

なんともはや、ストレートな対応方法でございますこと・・・。
んまともあれ、同様な方法で apache2.x + openssl 0.9.8 でも行けそうだと・・・。
でもまぁ、そのうち apache2.x でも openssl 0.9.8 対応とかも込みでversion upされるんでないっすかね。

|

« openssl 0.9.8 + apache2 | トップページ | アクセプト »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/4540/4925746

この記事へのトラックバック一覧です: mod_ssl 2.8.23 がリリースされました:

« openssl 0.9.8 + apache2 | トップページ | アクセプト »